Add CodeLite
This commit is contained in:
parent
2ace6bc9ca
commit
0d5ab36519
3 changed files with 160 additions and 0 deletions
1
dev-util/codelite/Manifest
Normal file
1
dev-util/codelite/Manifest
Normal file
|
@ -0,0 +1 @@
|
||||||
|
DIST codelite-17.0.0.tar.gz 33541958 BLAKE2B 6a5add30dad55b7b434ea3e2e9b9c9a23f3cf96da25afafa1a27ac27a4ce69dd369ad0d6eef13d827aa898ed9c01e04f0559fcf6b6eb86d77fedc469753b0183 SHA512 e36b6dcc37cd036a301a78714e8d5f2a61714b58fe006398fe0e959be59992dd7cc7d2a59661d364e371c750ca15cc21d4085d207738a7e3ede09ec0de125cff
|
40
dev-util/codelite/codelite-17.0.0.ebuild
Normal file
40
dev-util/codelite/codelite-17.0.0.ebuild
Normal file
|
@ -0,0 +1,40 @@
|
||||||
|
# Copyright 2024 Gentoo Authors
|
||||||
|
# Distributed under the terms of the GNU General Public License v2
|
||||||
|
|
||||||
|
EAPI=8
|
||||||
|
|
||||||
|
WX_GTK_VER="3.2-gtk3"
|
||||||
|
inherit cmake wxwidgets xdg
|
||||||
|
|
||||||
|
DESCRIPTION="CodeLite IDE"
|
||||||
|
HOMEPAGE="https://codelite.org/"
|
||||||
|
SRC_URI="https://github.com/eranif/codelite/releases/download/17.0.0/codelite-17.0.0.tar.gz"
|
||||||
|
S="${WORKDIR}/codelite-17.0"
|
||||||
|
|
||||||
|
LICENSE="GPL-2"
|
||||||
|
SLOT="0"
|
||||||
|
KEYWORDS="~amd64 ~ppc ~x86"
|
||||||
|
|
||||||
|
DEPEND="net-libs/libssh dev-db/sqlite x11-libs/wxGTK:${WX_GTK_VER}[X]"
|
||||||
|
RDEPEND="${DEPEND}"
|
||||||
|
BDEPEND="dev-build/cmake sys-devel/flex sys-devel/bison dev-libs/libpcre2 ${DEPEND}"
|
||||||
|
CMAKE_MAKEFILE_GENERATOR=emake
|
||||||
|
PATCHES=(
|
||||||
|
${FILESDIR}/fix-linux-build-1.patch
|
||||||
|
)
|
||||||
|
|
||||||
|
src_configure() {
|
||||||
|
setup-wxwidgets
|
||||||
|
local mycmakeargs=(
|
||||||
|
-DCOPY_WX_LIBS=0
|
||||||
|
)
|
||||||
|
cmake_src_configure
|
||||||
|
}
|
||||||
|
|
||||||
|
pkg_postinst() {
|
||||||
|
xdg_pkg_postinst
|
||||||
|
}
|
||||||
|
|
||||||
|
pkg_postrm() {
|
||||||
|
xdg_pkg_postrm
|
||||||
|
}
|
119
dev-util/codelite/files/fix-linux-build-1.patch
Normal file
119
dev-util/codelite/files/fix-linux-build-1.patch
Normal file
|
@ -0,0 +1,119 @@
|
||||||
|
diff '--color=auto' -ur a/CodeLite/istorage.h b/CodeLite/istorage.h
|
||||||
|
--- a/CodeLite/istorage.h 2023-01-11 13:18:07.000000000 -0800
|
||||||
|
+++ b/CodeLite/istorage.h 2024-10-12 17:56:58.381279220 -0700
|
||||||
|
@@ -31,6 +31,7 @@
|
||||||
|
#include "fileentry.h"
|
||||||
|
#include "pptable.h"
|
||||||
|
#include "tag_tree.h"
|
||||||
|
+#include <wx/filename.h>
|
||||||
|
|
||||||
|
#define MAX_SEARCH_LIMIT 250
|
||||||
|
|
||||||
|
diff '--color=auto' -ur a/CodeLite/MSYS2.cpp b/CodeLite/MSYS2.cpp
|
||||||
|
--- a/CodeLite/MSYS2.cpp 2023-01-11 13:18:07.000000000 -0800
|
||||||
|
+++ b/CodeLite/MSYS2.cpp 2024-10-12 18:29:03.811054914 -0700
|
||||||
|
@@ -6,6 +6,7 @@
|
||||||
|
#include <wx/arrstr.h>
|
||||||
|
#include <wx/stdpaths.h>
|
||||||
|
#include <wx/tokenzr.h>
|
||||||
|
+#include <wx/filename.h>
|
||||||
|
|
||||||
|
#ifdef __WXMSW__
|
||||||
|
#include <wx/msw/registry.h>
|
||||||
|
diff '--color=auto' -ur a/CodeLite/MSYS2.hpp b/CodeLite/MSYS2.hpp
|
||||||
|
--- a/CodeLite/MSYS2.hpp 2023-01-11 13:18:07.000000000 -0800
|
||||||
|
+++ b/CodeLite/MSYS2.hpp 2024-10-12 18:28:57.697962463 -0700
|
||||||
|
@@ -3,6 +3,7 @@
|
||||||
|
|
||||||
|
#include "PlatformCommon.hpp"
|
||||||
|
#include "codelite_exports.h"
|
||||||
|
+#include <wx/string.h>
|
||||||
|
|
||||||
|
class WXDLLIMPEXP_CL MSYS2 : public PlatformCommon
|
||||||
|
{
|
||||||
|
diff '--color=auto' -ur a/LanguageServer/LanguageServerLogView.cpp b/LanguageServer/LanguageServerLogView.cpp
|
||||||
|
--- a/LanguageServer/LanguageServerLogView.cpp 2023-01-11 13:18:07.000000000 -0800
|
||||||
|
+++ b/LanguageServer/LanguageServerLogView.cpp 2024-10-12 18:19:43.545674385 -0700
|
||||||
|
@@ -1,4 +1,5 @@
|
||||||
|
#include "LanguageServerLogView.h"
|
||||||
|
+#include <wx/menu.h>
|
||||||
|
|
||||||
|
LanguageServerLogView::LanguageServerLogView(wxWindow* parent)
|
||||||
|
: LanguageServerLogViewBase(parent)
|
||||||
|
diff '--color=auto' -ur a/LiteEditor/clConfigurationSelectionCtrl.h b/LiteEditor/clConfigurationSelectionCtrl.h
|
||||||
|
--- a/LiteEditor/clConfigurationSelectionCtrl.h 2023-01-11 13:18:07.000000000 -0800
|
||||||
|
+++ b/LiteEditor/clConfigurationSelectionCtrl.h 2024-10-12 18:27:53.567171697 -0700
|
||||||
|
@@ -6,6 +6,7 @@
|
||||||
|
|
||||||
|
#include <wx/arrstr.h>
|
||||||
|
#include <wx/panel.h>
|
||||||
|
+#include <wx/choice.h>
|
||||||
|
|
||||||
|
#define OPEN_CONFIG_MGR_STR _("Open Workspace Configuration Manager...")
|
||||||
|
|
||||||
|
diff '--color=auto' -ur a/Plugin/clEditorEditEventsHandler.cpp b/Plugin/clEditorEditEventsHandler.cpp
|
||||||
|
--- a/Plugin/clEditorEditEventsHandler.cpp 2023-01-11 13:18:07.000000000 -0800
|
||||||
|
+++ b/Plugin/clEditorEditEventsHandler.cpp 2024-10-12 18:09:38.126611843 -0700
|
||||||
|
@@ -6,6 +6,7 @@
|
||||||
|
#include <wx/stc/stc.h>
|
||||||
|
#include <wx/textctrl.h>
|
||||||
|
#include <wx/textentry.h>
|
||||||
|
+#include <wx/app.h>
|
||||||
|
|
||||||
|
clEditEventsHandler::clEditEventsHandler(wxStyledTextCtrl* wnd, const wxString& name)
|
||||||
|
: m_stc(wnd)
|
||||||
|
diff '--color=auto' -ur a/Plugin/clFileSystemWorkspaceView.hpp b/Plugin/clFileSystemWorkspaceView.hpp
|
||||||
|
--- a/Plugin/clFileSystemWorkspaceView.hpp 2023-01-11 13:18:07.000000000 -0800
|
||||||
|
+++ b/Plugin/clFileSystemWorkspaceView.hpp 2024-10-12 18:19:50.465425811 -0700
|
||||||
|
@@ -6,6 +6,7 @@
|
||||||
|
#include "clTreeCtrlPanel.h"
|
||||||
|
#include "cl_command_event.h"
|
||||||
|
#include "cl_config.h"
|
||||||
|
+#include <wx/choice.h>
|
||||||
|
|
||||||
|
class clThemedButton;
|
||||||
|
class WXDLLIMPEXP_SDK clFileSystemWorkspaceView : public clTreeCtrlPanel
|
||||||
|
diff '--color=auto' -ur a/Plugin/clPluginsFindBar.h b/Plugin/clPluginsFindBar.h
|
||||||
|
--- a/Plugin/clPluginsFindBar.h 2023-01-11 13:18:07.000000000 -0800
|
||||||
|
+++ b/Plugin/clPluginsFindBar.h 2024-10-12 17:58:51.071017791 -0700
|
||||||
|
@@ -33,6 +33,7 @@
|
||||||
|
#include <codelite_exports.h>
|
||||||
|
#include <wx/combobox.h>
|
||||||
|
#include <wx/panel.h>
|
||||||
|
+#include <wx/stattext.h>
|
||||||
|
|
||||||
|
class wxStyledTextCtrl;
|
||||||
|
|
||||||
|
diff '--color=auto' -ur a/Plugin/DiffUI.h b/Plugin/DiffUI.h
|
||||||
|
--- a/Plugin/DiffUI.h 2023-01-11 13:18:07.000000000 -0800
|
||||||
|
+++ b/Plugin/DiffUI.h 2024-10-12 18:01:58.788299095 -0700
|
||||||
|
@@ -29,6 +29,7 @@
|
||||||
|
#include <wx/persist/toplevel.h>
|
||||||
|
#include <wx/persist/treebook.h>
|
||||||
|
#endif
|
||||||
|
+#include <wx/frame.h>
|
||||||
|
|
||||||
|
#ifdef WXC_FROM_DIP
|
||||||
|
#undef WXC_FROM_DIP
|
||||||
|
diff '--color=auto' -ur a/Plugin/dtl/Diff.hpp b/Plugin/dtl/Diff.hpp
|
||||||
|
--- a/Plugin/dtl/Diff.hpp 2023-01-11 13:18:07.000000000 -0800
|
||||||
|
+++ b/Plugin/dtl/Diff.hpp 2024-10-12 18:08:01.649783853 -0700
|
||||||
|
@@ -165,7 +165,7 @@
|
||||||
|
|
||||||
|
bool trivialEnabled() const { return trivial; }
|
||||||
|
|
||||||
|
- void enableTrivial() const { this->trivial = true; }
|
||||||
|
+ void enableTrivial() { this->trivial = true; }
|
||||||
|
|
||||||
|
void disableTrivial() { this->trivial = false; }
|
||||||
|
|
||||||
|
diff '--color=auto' -ur a/Remoty/sample_codelite_remote_json.cpp b/Remoty/sample_codelite_remote_json.cpp
|
||||||
|
--- a/Remoty/sample_codelite_remote_json.cpp 2023-01-11 13:18:07.000000000 -0800
|
||||||
|
+++ b/Remoty/sample_codelite_remote_json.cpp 2024-10-12 18:23:18.591278745 -0700
|
||||||
|
@@ -1,5 +1,6 @@
|
||||||
|
#ifndef SAMPLE_CODELITE_REMOTE_JSON_HPP
|
||||||
|
#define SAMPLE_CODELITE_REMOTE_JSON_HPP
|
||||||
|
+#include <wx/string.h>
|
||||||
|
|
||||||
|
const wxString DEFAULT_CODELITE_REMOTE_JSON = R"EOF(
|
||||||
|
{
|
Loading…
Reference in a new issue