Add CodeLite

This commit is contained in:
Zachary Hall 2024-10-12 17:11:36 -07:00
parent 2ace6bc9ca
commit aa20bb9150
3 changed files with 54 additions and 0 deletions

View file

@ -0,0 +1 @@
DIST codelite-17.0.0.tar.gz 33541958 BLAKE2B 6a5add30dad55b7b434ea3e2e9b9c9a23f3cf96da25afafa1a27ac27a4ce69dd369ad0d6eef13d827aa898ed9c01e04f0559fcf6b6eb86d77fedc469753b0183 SHA512 e36b6dcc37cd036a301a78714e8d5f2a61714b58fe006398fe0e959be59992dd7cc7d2a59661d364e371c750ca15cc21d4085d207738a7e3ede09ec0de125cff

View file

@ -0,0 +1,40 @@
# Copyright 2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
WX_GTK_VER="3.2-gtk3"
inherit cmake wxwidgets xdg
DESCRIPTION="CodeLite IDE"
HOMEPAGE="https://codelite.org/"
SRC_URI="https://github.com/eranif/codelite/releases/download/17.0.0/codelite-17.0.0.tar.gz"
S="${WORKDIR}/codelite-17.0"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
DEPEND="net-libs/libssh dev-db/sqlite x11-libs/wxGTK:${WX_GTK_VER}[X]"
RDEPEND="${DEPEND}"
BDEPEND="dev-build/cmake sys-devel/flex sys-devel/bison dev-libs/libpcre2"
CMAKE_MAKEFILE_GENERATOR=emake
PATCHES=(
${FILESDIR}/fix-linux-build-1.patch
)
src_configure() {
setup-wxwidgets
local mycmakeargs=(
-DCOPY_WX_LIBS=0
)
cmake_src_configure
}
pkg_postinst() {
xdg_pkg_postinst
}
pkg_postrm() {
xdg_pkg_postrm
}

View file

@ -0,0 +1,13 @@
--- a/CodeLite/CMakeLists.txt 2024-10-13 00:26:50.429927711 -0000
+++ b/CodeLite/CMakeLists.txt 2024-10-13 00:26:12.869931690 -0000
@@ -105,6 +105,10 @@
endif()
file(GLOB SRCS "*.cpp" "../sdk/codelite_indexer/network/*.cpp" "SocketAPI/*.cpp" "LSP/*.cpp")
+if(NOT MINGW)
+ list(REMOVE_ITEM SRCS "MSYS2.cpp" "MSYS2.hpp")
+endif()
+
# Define GTK libraries
if(GTK2_FOUND)
set(GTK_LIBS "${GTK2_LIBRARIES}")