Add CodeLite
This commit is contained in:
parent
2ace6bc9ca
commit
b603ceaddf
3 changed files with 88 additions and 0 deletions
1
dev-util/codelite/Manifest
Normal file
1
dev-util/codelite/Manifest
Normal file
|
@ -0,0 +1 @@
|
||||||
|
DIST codelite-17.0.0.tar.gz 33541958 BLAKE2B 6a5add30dad55b7b434ea3e2e9b9c9a23f3cf96da25afafa1a27ac27a4ce69dd369ad0d6eef13d827aa898ed9c01e04f0559fcf6b6eb86d77fedc469753b0183 SHA512 e36b6dcc37cd036a301a78714e8d5f2a61714b58fe006398fe0e959be59992dd7cc7d2a59661d364e371c750ca15cc21d4085d207738a7e3ede09ec0de125cff
|
40
dev-util/codelite/codelite-17.0.0.ebuild
Normal file
40
dev-util/codelite/codelite-17.0.0.ebuild
Normal file
|
@ -0,0 +1,40 @@
|
||||||
|
# Copyright 2024 Gentoo Authors
|
||||||
|
# Distributed under the terms of the GNU General Public License v2
|
||||||
|
|
||||||
|
EAPI=8
|
||||||
|
|
||||||
|
WX_GTK_VER="3.2-gtk3"
|
||||||
|
inherit cmake wxwidgets xdg
|
||||||
|
|
||||||
|
DESCRIPTION="CodeLite IDE"
|
||||||
|
HOMEPAGE="https://codelite.org/"
|
||||||
|
SRC_URI="https://github.com/eranif/codelite/releases/download/17.0.0/codelite-17.0.0.tar.gz"
|
||||||
|
S="${WORKDIR}/codelite-17.0"
|
||||||
|
|
||||||
|
LICENSE="GPL-2"
|
||||||
|
SLOT="0"
|
||||||
|
KEYWORDS="~amd64 ~ppc ~x86"
|
||||||
|
|
||||||
|
DEPEND="net-libs/libssh dev-db/sqlite x11-libs/wxGTK:${WX_GTK_VER}[X]"
|
||||||
|
RDEPEND="${DEPEND}"
|
||||||
|
BDEPEND="dev-build/cmake sys-devel/flex sys-devel/bison dev-libs/libpcre2 ${DEPEND}"
|
||||||
|
CMAKE_MAKEFILE_GENERATOR=emake
|
||||||
|
PATCHES=(
|
||||||
|
${FILESDIR}/fix-linux-build-1.patch
|
||||||
|
)
|
||||||
|
|
||||||
|
src_configure() {
|
||||||
|
setup-wxwidgets
|
||||||
|
local mycmakeargs=(
|
||||||
|
-DCOPY_WX_LIBS=0
|
||||||
|
)
|
||||||
|
cmake_src_configure
|
||||||
|
}
|
||||||
|
|
||||||
|
pkg_postinst() {
|
||||||
|
xdg_pkg_postinst
|
||||||
|
}
|
||||||
|
|
||||||
|
pkg_postrm() {
|
||||||
|
xdg_pkg_postrm
|
||||||
|
}
|
47
dev-util/codelite/files/fix-linux-build-1.patch
Normal file
47
dev-util/codelite/files/fix-linux-build-1.patch
Normal file
|
@ -0,0 +1,47 @@
|
||||||
|
diff '--color=auto' -ur a/CodeLite/CMakeLists.txt b/CodeLite/CMakeLists.txt
|
||||||
|
--- a/CodeLite/CMakeLists.txt 2023-01-11 13:18:07.000000000 -0800
|
||||||
|
+++ b/CodeLite/CMakeLists.txt 2024-10-12 17:56:58.381279220 -0700
|
||||||
|
@@ -105,6 +105,10 @@
|
||||||
|
endif()
|
||||||
|
file(GLOB SRCS "*.cpp" "../sdk/codelite_indexer/network/*.cpp" "SocketAPI/*.cpp" "LSP/*.cpp")
|
||||||
|
|
||||||
|
+if(NOT MINGW)
|
||||||
|
+ list(REMOVE_ITEM SRCS "${CMAKE_CURRENT_SOURCE_DIR}/MSYS2.cpp")
|
||||||
|
+endif()
|
||||||
|
+
|
||||||
|
# Define GTK libraries
|
||||||
|
if(GTK2_FOUND)
|
||||||
|
set(GTK_LIBS "${GTK2_LIBRARIES}")
|
||||||
|
diff '--color=auto' -ur a/CodeLite/istorage.h b/CodeLite/istorage.h
|
||||||
|
--- a/CodeLite/istorage.h 2023-01-11 13:18:07.000000000 -0800
|
||||||
|
+++ b/CodeLite/istorage.h 2024-10-12 17:56:58.381279220 -0700
|
||||||
|
@@ -31,6 +31,7 @@
|
||||||
|
#include "fileentry.h"
|
||||||
|
#include "pptable.h"
|
||||||
|
#include "tag_tree.h"
|
||||||
|
+#include <wx/filename.h>
|
||||||
|
|
||||||
|
#define MAX_SEARCH_LIMIT 250
|
||||||
|
|
||||||
|
diff '--color=auto' -ur a/Plugin/clPluginsFindBar.h b/Plugin/clPluginsFindBar.h
|
||||||
|
--- a/Plugin/clPluginsFindBar.h 2023-01-11 13:18:07.000000000 -0800
|
||||||
|
+++ b/Plugin/clPluginsFindBar.h 2024-10-12 17:58:51.071017791 -0700
|
||||||
|
@@ -33,6 +33,7 @@
|
||||||
|
#include <codelite_exports.h>
|
||||||
|
#include <wx/combobox.h>
|
||||||
|
#include <wx/panel.h>
|
||||||
|
+#include <wx/stattext.h>
|
||||||
|
|
||||||
|
class wxStyledTextCtrl;
|
||||||
|
|
||||||
|
diff '--color=auto' -ur a/Plugin/DiffUI.h b/Plugin/DiffUI.h
|
||||||
|
--- a/Plugin/DiffUI.h 2023-01-11 13:18:07.000000000 -0800
|
||||||
|
+++ b/Plugin/DiffUI.h 2024-10-12 18:01:58.788299095 -0700
|
||||||
|
@@ -29,6 +29,7 @@
|
||||||
|
#include <wx/persist/toplevel.h>
|
||||||
|
#include <wx/persist/treebook.h>
|
||||||
|
#endif
|
||||||
|
+#include <wx/frame.h>
|
||||||
|
|
||||||
|
#ifdef WXC_FROM_DIP
|
||||||
|
#undef WXC_FROM_DIP
|
Loading…
Reference in a new issue