84 lines
2.9 KiB
Diff
84 lines
2.9 KiB
Diff
diff '--color=auto' -ur a/CodeLite/CMakeLists.txt b/CodeLite/CMakeLists.txt
|
|
--- a/CodeLite/CMakeLists.txt 2023-01-11 13:18:07.000000000 -0800
|
|
+++ b/CodeLite/CMakeLists.txt 2024-10-12 17:56:58.381279220 -0700
|
|
@@ -105,6 +105,10 @@
|
|
endif()
|
|
file(GLOB SRCS "*.cpp" "../sdk/codelite_indexer/network/*.cpp" "SocketAPI/*.cpp" "LSP/*.cpp")
|
|
|
|
+if(NOT MINGW)
|
|
+ list(REMOVE_ITEM SRCS "${CMAKE_CURRENT_SOURCE_DIR}/MSYS2.cpp")
|
|
+endif()
|
|
+
|
|
# Define GTK libraries
|
|
if(GTK2_FOUND)
|
|
set(GTK_LIBS "${GTK2_LIBRARIES}")
|
|
diff '--color=auto' -ur a/CodeLite/istorage.h b/CodeLite/istorage.h
|
|
--- a/CodeLite/istorage.h 2023-01-11 13:18:07.000000000 -0800
|
|
+++ b/CodeLite/istorage.h 2024-10-12 17:56:58.381279220 -0700
|
|
@@ -31,6 +31,7 @@
|
|
#include "fileentry.h"
|
|
#include "pptable.h"
|
|
#include "tag_tree.h"
|
|
+#include <wx/filename.h>
|
|
|
|
#define MAX_SEARCH_LIMIT 250
|
|
|
|
diff '--color=auto' -ur a/Plugin/clEditorEditEventsHandler.cpp b/Plugin/clEditorEditEventsHandler.cpp
|
|
--- a/Plugin/clEditorEditEventsHandler.cpp 2023-01-11 13:18:07.000000000 -0800
|
|
+++ b/Plugin/clEditorEditEventsHandler.cpp 2024-10-12 18:09:38.126611843 -0700
|
|
@@ -6,6 +6,7 @@
|
|
#include <wx/stc/stc.h>
|
|
#include <wx/textctrl.h>
|
|
#include <wx/textentry.h>
|
|
+#include <wx/app.h>
|
|
|
|
clEditEventsHandler::clEditEventsHandler(wxStyledTextCtrl* wnd, const wxString& name)
|
|
: m_stc(wnd)
|
|
diff '--color=auto' -ur a/Plugin/clFileSystemWorkspaceView.hpp b/Plugin/clFileSystemWorkspaceView.hpp
|
|
--- a/Plugin/clFileSystemWorkspaceView.hpp 2023-01-11 13:18:07.000000000 -0800
|
|
+++ b/Plugin/clFileSystemWorkspaceView.hpp 2024-10-12 18:15:50.844026929 -0700
|
|
@@ -6,6 +6,10 @@
|
|
#include "clTreeCtrlPanel.h"
|
|
#include "cl_command_event.h"
|
|
#include "cl_config.h"
|
|
+#include <wx/choice.h>
|
|
+#ifdef __unix__
|
|
+#include <wx/gtk/choice.h>
|
|
+#endif
|
|
|
|
class clThemedButton;
|
|
class WXDLLIMPEXP_SDK clFileSystemWorkspaceView : public clTreeCtrlPanel
|
|
diff '--color=auto' -ur a/Plugin/clPluginsFindBar.h b/Plugin/clPluginsFindBar.h
|
|
--- a/Plugin/clPluginsFindBar.h 2023-01-11 13:18:07.000000000 -0800
|
|
+++ b/Plugin/clPluginsFindBar.h 2024-10-12 17:58:51.071017791 -0700
|
|
@@ -33,6 +33,7 @@
|
|
#include <codelite_exports.h>
|
|
#include <wx/combobox.h>
|
|
#include <wx/panel.h>
|
|
+#include <wx/stattext.h>
|
|
|
|
class wxStyledTextCtrl;
|
|
|
|
diff '--color=auto' -ur a/Plugin/DiffUI.h b/Plugin/DiffUI.h
|
|
--- a/Plugin/DiffUI.h 2023-01-11 13:18:07.000000000 -0800
|
|
+++ b/Plugin/DiffUI.h 2024-10-12 18:01:58.788299095 -0700
|
|
@@ -29,6 +29,7 @@
|
|
#include <wx/persist/toplevel.h>
|
|
#include <wx/persist/treebook.h>
|
|
#endif
|
|
+#include <wx/frame.h>
|
|
|
|
#ifdef WXC_FROM_DIP
|
|
#undef WXC_FROM_DIP
|
|
diff '--color=auto' -ur a/Plugin/dtl/Diff.hpp b/Plugin/dtl/Diff.hpp
|
|
--- a/Plugin/dtl/Diff.hpp 2023-01-11 13:18:07.000000000 -0800
|
|
+++ b/Plugin/dtl/Diff.hpp 2024-10-12 18:08:01.649783853 -0700
|
|
@@ -165,7 +165,7 @@
|
|
|
|
bool trivialEnabled() const { return trivial; }
|
|
|
|
- void enableTrivial() const { this->trivial = true; }
|
|
+ void enableTrivial() { this->trivial = true; }
|
|
|
|
void disableTrivial() { this->trivial = false; }
|
|
|