gentoo_catmeow_repo/dev-util/codelite/files/fix-linux-build-1.patch
2024-10-12 17:54:12 -07:00

25 lines
847 B
Diff

diff '--color=auto' -ur a/CodeLite/CMakeLists.txt b/CodeLite/CMakeLists.txt
--- a/CodeLite/CMakeLists.txt 2023-01-11 21:18:07.000000000 -0000
+++ b/CodeLite/CMakeLists.txt 2024-10-13 00:50:40.465027666 -0000
@@ -105,6 +105,10 @@
endif()
file(GLOB SRCS "*.cpp" "../sdk/codelite_indexer/network/*.cpp" "SocketAPI/*.cpp" "LSP/*.cpp")
+if(NOT MINGW)
+ list(REMOVE_ITEM SRCS "${CMAKE_CURRENT_SOURCE_DIR}/MSYS2.cpp")
+endif()
+
# Define GTK libraries
if(GTK2_FOUND)
set(GTK_LIBS "${GTK2_LIBRARIES}")
diff '--color=auto' -ur a/CodeLite/istorage.h b/CodeLite/istorage.h
--- a/CodeLite/istorage.h 2023-01-11 21:18:07.000000000 -0000
+++ b/CodeLite/istorage.h 2024-10-13 00:53:01.374795375 -0000
@@ -31,6 +31,7 @@
#include "fileentry.h"
#include "pptable.h"
#include "tag_tree.h"
+#include <wx/filename.h>
#define MAX_SEARCH_LIMIT 250