looper/debian/rules
Zachary Hall cb0b4cf1e7
Some checks failed
Build / build-gentoo (push) Failing after 1m12s
Build / download-system-deps (push) Successful in 3m30s
Build / get-source-code (push) Successful in 11m26s
Build / build-deb (push) Successful in 10m38s
Build / build-appimage (push) Successful in 4m30s
Build / build-android (push) Failing after 3m1s
Build / build-windows (push) Failing after 7m18s
Hopefully fix DEB workflow
2024-12-19 09:00:34 -08:00

33 lines
937 B
Makefile
Executable file

#!/usr/bin/make -f
# See debhelper(7) (uncomment to enable).
# Output every command that modifies files on the build system.
#export DH_VERBOSE = 1
# See FEATURE AREAS in dpkg-buildflags(1).
#export DEB_BUILD_MAINT_OPTIONS = hardening=+all
# See ENVIRONMENT in dpkg-buildflags(1).
# Package maintainers to append CFLAGS.
#export DEB_CFLAGS_MAINT_APPEND = -Wall -pedantic
# Package maintainers to append LDFLAGS.
#export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
%:
dh $@
# dh_make generated override targets.
# This is an example for Cmake (see <https://bugs.debian.org/641051>).
override_dh_auto_configure:
git submodule update --init --recursive -- backends/ui/imgui/imgui subprojects/vgmstream subprojects/SDL-Mixer-X
dh_auto_configure -- \
-DBUILD_SOUNDTOUCH=OFF \
-DMIXERX_ENABLE_GPL=ON \
-DMIXERX_ENABLE_LGPL=ON \
-DUSE_G719=OFF \
-DUSE_SPEEX=OFF \
-DUSE_ATRAC9=OFF \
-DCMAKE_LIBRARY_PATH=$(DEB_HOST_MULTIARCH)